Quantcast

Blue Arrows on Per-Machine Shortcut Icons

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Blue Arrows on Per-Machine Shortcut Icons

drusso
This post has NOT been accepted by the mailing list yet.
When I try to do a per-machine installation of my package, I'm getting these strange blue arrows on the Desktop and program menu, and startup shortcuts. I'm referring to the arrows in the upper-right corner:



I'm using Wix Tooslet 3.10.2.2516, but the same thing happened when I tried the prior stable release. I'm installing the shortcuts like this:


<Package Description="MY PACKAGE" InstallScope="perMachine" Compressed="yes" />
<Component Id="MINE" Guid="MINE">
  <File Id="MINE.exe" Name="MINE.exe" Source="MINE.exe" KeyPath="yes">
    <Shortcut Id="MY_SHORCUT" Directory="DesktopFolder" Name="MY PACKAGE"
      WorkingDirectory="INSTALLDIR" Icon="MINE.exe" IconIndex="0" Advertise="yes" /
  </File>
  ...


If I remove the InstallScope="perMachine" from the Package element and the icons are installed in the user directories the blue arrows do not appear!

What gives, any ideas?


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Blue Arrows on Per-Machine Shortcut Icons

elliotl
This post has NOT been accepted by the mailing list yet.
I am getting the same thing. Apparently, these blue arrows are intended to indicate a compressed file in Windows 10. I only see this problem when installing on my Windows 10 machine, not in 7 or 8.1.

I am a bit freaked out about this, because I thought that I was days away from the end of a year long release cycle.

I am preparing a single file bootstrapper .exe that installs multiple .msi's so I really want the compression options to just work without weird side effects. Does anyone know how to fix this?
Loading...