Compiling with pubca schema

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Compiling with pubca schema

Barco
I've been following the instructions in this message to add some COM+
registration  :

http://sourceforge.net/mailarchive/message.php?msg_id=11745361

I added "xmlns:pca=........" at the top as shown in the example and
then put <pca:ComPlusApplication ......... etc under the Component
element.

However, when compiling with candle I get the error "The Component
element contains an unexpected child element 'pca:ComPlusPartition'".

I've got "-ext Microsoft.Tools.WindowsInstallerXml.PcaCompiler,pcaext"
as a parameter to candle.

Has something changed since these instructions were written?


-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server. Download
it for free - -and be entered to win a 42" plasma tv or your very own
Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
_______________________________________________
WiX-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/wix-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Compiling with pubca schema

Fredrik Grohn
Hmm, that's odd. No, nothing has changed; it should work. What version of the toolset are you using? Is there any chance you could send an example .wxs file plus the command lines you used to produce the error?

I tried out the latest binaries from SourceForge myself, and candle works for me. However I got a linker error when importing the ComPlusAssembly table that doesn't happen with my current local build, with is quite disturbing. I'll have a look at this later tonight...

Fred

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Barco
Sent: Monday, September 19, 2005 11:50 AM
To: [hidden email]
Subject: [WiX-users] Compiling with pubca schema

I've been following the instructions in this message to add some COM+
registration  :

http://sourceforge.net/mailarchive/message.php?msg_id=11745361

I added "xmlns:pca=........" at the top as shown in the example and
then put <pca:ComPlusApplication ......... etc under the Component
element.

However, when compiling with candle I get the error "The Component
element contains an unexpected child element 'pca:ComPlusPartition'".

I've got "-ext Microsoft.Tools.WindowsInstallerXml.PcaCompiler,pcaext"
as a parameter to candle.

Has something changed since these instructions were written?


-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server. Download
it for free - -and be entered to win a 42" plasma tv or your very own
Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
_______________________________________________
WiX-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/wix-users


-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server. Download
it for free - -and be entered to win a 42" plasma tv or your very own
Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
_______________________________________________
WiX-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/wix-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Compiling with pubca schema

Barco
It's OK Fredrik. It was entirely my fault. I had a batch file to
compile various wix projects and I'd added the "-ext ...." part to the
wrong line. It now compiles and links fine.

Is there any documentation for the ComPlus elements apart from the wix.chm file?


On 19/09/05, Fredrik Grohn <[hidden email]> wrote:

> Hmm, that's odd. No, nothing has changed; it should work. What version of the toolset are you using? Is there any chance you could send an example .wxs file plus the command lines you used to produce the error?
>
> I tried out the latest binaries from SourceForge myself, and candle works for me. However I got a linker error when importing the ComPlusAssembly table that doesn't happen with my current local build, with is quite disturbing. I'll have a look at this later tonight...
>
> Fred
>
> -----Original Message-----
> From: [hidden email] [mailto:[hidden email]] On Behalf Of Barco
> Sent: Monday, September 19, 2005 11:50 AM
> To: [hidden email]
> Subject: [WiX-users] Compiling with pubca schema
>
> I've been following the instructions in this message to add some COM+
> registration  :
>
> http://sourceforge.net/mailarchive/message.php?msg_id=11745361
>
> I added "xmlns:pca=........" at the top as shown in the example and
> then put <pca:ComPlusApplication ......... etc under the Component
> element.
>
> However, when compiling with candle I get the error "The Component
> element contains an unexpected child element 'pca:ComPlusPartition'".
>
> I've got "-ext Microsoft.Tools.WindowsInstallerXml.PcaCompiler,pcaext"
> as a parameter to candle.
>
> Has something changed since these instructions were written?
>
>
> -------------------------------------------------------
> SF.Net email is sponsored by:
> Tame your development challenges with Apache's Geronimo App Server. Download
> it for free - -and be entered to win a 42" plasma tv or your very own
> Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
> _______________________________________________
> WiX-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/wix-users
>


-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server. Download
it for free - -and be entered to win a 42" plasma tv or your very own
Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
_______________________________________________
WiX-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/wix-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Compiling with pubca schema

Fredrik Grohn
In reply to this post by Barco
Yes, there are two documents describing the XML schema and the MSI database schema respectively.

XML schema:
http://wix.sourceforge.net/cpi/cpi_xsd_v0.2.html

Database schema:
http://wix.sourceforge.net/cpi/cpi_tables_v0.4.html

The XML schema documentation will be included in wix.chm, and is currently pending in CVS.

Fred

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Barco
Sent: Tuesday, September 20, 2005 10:16 AM
To: [hidden email]
Subject: Re: [WiX-users] Compiling with pubca schema

It's OK Fredrik. It was entirely my fault. I had a batch file to
compile various wix projects and I'd added the "-ext ...." part to the
wrong line. It now compiles and links fine.

Is there any documentation for the ComPlus elements apart from the wix.chm file?


On 19/09/05, Fredrik Grohn <[hidden email]> wrote:

> Hmm, that's odd. No, nothing has changed; it should work. What version of the toolset are you using? Is there any chance you could send an example .wxs file plus the command lines you used to produce the error?
>
> I tried out the latest binaries from SourceForge myself, and candle works for me. However I got a linker error when importing the ComPlusAssembly table that doesn't happen with my current local build, with is quite disturbing. I'll have a look at this later tonight...
>
> Fred
>
> -----Original Message-----
> From: [hidden email] [mailto:[hidden email]] On Behalf Of Barco
> Sent: Monday, September 19, 2005 11:50 AM
> To: [hidden email]
> Subject: [WiX-users] Compiling with pubca schema
>
> I've been following the instructions in this message to add some COM+
> registration  :
>
> http://sourceforge.net/mailarchive/message.php?msg_id=11745361
>
> I added "xmlns:pca=........" at the top as shown in the example and
> then put <pca:ComPlusApplication ......... etc under the Component
> element.
>
> However, when compiling with candle I get the error "The Component
> element contains an unexpected child element 'pca:ComPlusPartition'".
>
> I've got "-ext Microsoft.Tools.WindowsInstallerXml.PcaCompiler,pcaext"
> as a parameter to candle.
>
> Has something changed since these instructions were written?
>
>
> -------------------------------------------------------
> SF.Net email is sponsored by:
> Tame your development challenges with Apache's Geronimo App Server. Download
> it for free - -and be entered to win a 42" plasma tv or your very own
> Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
> _______________________________________________
> WiX-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/wix-users
>


-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server. Download
it for free - -and be entered to win a 42" plasma tv or your very own
Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
_______________________________________________
WiX-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/wix-users


-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server. Download
it for free - -and be entered to win a 42" plasma tv or your very own
Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
_______________________________________________
WiX-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/wix-users
Loading...