Removing IIS Websites and WebAppPools after uninstalling

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Removing IIS Websites and WebAppPools after uninstalling

Gokul Raj
This post has NOT been accepted by the mailing list yet.
This post was updated on .
In Wix build, at installation time, User can enter their Website name and WebAppPool name.

I have property to store those values. I am using to register to have all value.

But While un-installing build, Website and Pool are not removed.

How do i say to Wix to remove the specific website at un-install?

Please help me and thanks in advance.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Removing IIS Websites and WebAppPools after uninstalling

Namrata
This post has NOT been accepted by the mailing list yet.
What code you are trying to remove website and pool?  And also is that IIS7?
Please try resetting IIS after removing these.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Removing IIS Websites and WebAppPools after uninstalling

Gokul Raj
This post has NOT been accepted by the mailing list yet.
Hi Namrata,

I used Wix property to store the Website name and WebPoolName.
At installation time, User can able to change those values.

At un-installation phase, those weebsites are not removed.


We stored those values in REGISTRY.
At un-install i set those property, after reading from registry.

It was worked. Thanks for reply:)
Loading...