[ wix-Bugs-1284004 ] Fragment not included

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[ wix-Bugs-1284004 ] Fragment not included

SourceForge.net
Bugs item #1284004, was opened at 09/07/05 07:20
Message generated for change (Comment added) made by sf-robot
You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=642714&aid=1284004&group_id=105970

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: candle
Group: v2.0
>Status: Closed
Resolution: Fixed
Priority: 5
Submitted By: koffeinkick (koffeinkick)
Assigned to: Derek (derekc)
Summary: Fragment not included

Initial Comment:
The following fragment is not included in the msi file if it
is only referenced by <Control>-tags:

<?xml version="1.0" encoding="utf-8"?>
<Wix
xmlns="http://schemas.microsoft.com/wix/2003/01/wi">
  <Fragment>
    <Binary Id="background.bmp"
src="bin\InstallationGfx\background.bmp" />
  </Fragment>
</Wix>

Referenced like this:

        <Control Id="Image" Type="Bitmap" X="0" Y="0"
Width="374" Height="234" Text="background.bmp">
        </Control>



----------------------------------------------------------------------

>Comment By: SourceForge Robot (sf-robot)
Date: 10/06/05 19:20

Message:
Logged In: YES
user_id=1312539

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

----------------------------------------------------------------------

Comment By: Derek (derekc)
Date: 09/22/05 10:47

Message:
Logged In: YES
user_id=518766

Should be fixed in the next drop.

----------------------------------------------------------------------

Comment By: Derek (derekc)
Date: 09/20/05 15:49

Message:
Logged In: YES
user_id=518766

While testing this fix, I noticed that the field is
formatted.  This means the value of the Text field could be
something like: "[PropertyContainingBinaryId]".

So, I'm looking for opinions: would it be advisable to make
the compiler do a "best effort" and create the foreign key
relationship if it doesn't find "[" inside the value?
Please note that even this will be less-than-ideal because
someone could make a Binary id with '[' in the name and then
a relationship wouldn't be created.

Or should we strive for consistency and leave detecting this
problem up to the ICEs?  (if there even is one to detect
this issue - I'm not sure)

----------------------------------------------------------------------

Comment By: Derek (derekc)
Date: 09/16/05 16:07

Message:
Logged In: YES
user_id=518766

Good call - I'm getting the fix for this reviewed now.

----------------------------------------------------------------------

You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=642714&aid=1284004&group_id=105970


-------------------------------------------------------
This SF.Net email is sponsored by:
Power Architecture Resource Center: Free content, downloads, discussions,
and more. http://solutions.newsforge.com/ibmarch.tmpl
_______________________________________________
WiX-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/wix-devs