[wix-users] (deprecated) Error loading prerequisite bootstrapper application because managed host could not be loaded

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[wix-users] (deprecated) Error loading prerequisite bootstrapper application because managed host could not be loaded

tonic889
I am getting "Error loading prerequisite bootstrapper application because
managed host could not be loaded" in the logs of my custom bootstrapper.
Originally I was using burn 3.9.2, and receiving error code 0x80004001. On
the advice of this thread (http://tinyurl.com/pt9ym65) I tried upgrading to
3.10.0.1823 but am still receiving the same error, only with a different
error code: 0x80131700.

My bootstrapper is targeting .NET 3.5 and is installing 4.5 as a
prerequisite.  Curiously enough, I am initially able to install .NET 4.5,
and load my custom bootstrapper.  However, if I subsequently uninstall .NET
via ARP, and run my bootstrapper a 2nd time, then I consistently get the
above error.  The test environment is running Windows 7 with .NET 3.5
enabled.  Here is my bootstrappercore.config

<?xml version="1.0" encoding="utf-8" ?>
<configuration>

  <configSections>
    <sectionGroup name="wix.bootstrapper"
type="Microsoft.Tools.WindowsInstallerXml.Bootstrapper.BootstrapperSectionGroup,
BootstrapperCore">
      <section name="host"
type="Microsoft.Tools.WindowsInstallerXml.Bootstrapper.HostSection,
BootstrapperCore" />
    </sectionGroup>
  </configSections>

  <startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v4.0" />
  </startup>

  <wix.bootstrapper>
    <host assemblyName="MyBootstrapperApplication">
      <supportedFramework version="v3.5" />
    </host>
  </wix.bootstrapper>

</configuration>

Can someone please advise whether this is a WiX bug or I am doing something
wrong?  Thanks in advance.

Brian
------------------------------------------------------------------------------
_______________________________________________
WiX-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/wix-users
Reply | Threaded
Open this post in threaded view
|

Re: (deprecated) Error loading prerequisite bootstrapper application because managed host could not be loaded

SeanHall
I would bet that the problem is that the supportedFramework element is v3.5
(which is the 2.0 runtime) but there's no supportedRuntime element for the
2.0 CLR.

P.S. Please use the new mailing list, information is at
http://wixtoolset.org/documentation/mailinglist/

On Mon, Jul 27, 2015 at 2:10 PM, Brian C Cooke <[hidden email]> wrote:

> I am getting "Error loading prerequisite bootstrapper application because
> managed host could not be loaded" in the logs of my custom bootstrapper.
> Originally I was using burn 3.9.2, and receiving error code 0x80004001. On
> the advice of this thread (http://tinyurl.com/pt9ym65) I tried upgrading
> to
> 3.10.0.1823 but am still receiving the same error, only with a different
> error code: 0x80131700.
>
> My bootstrapper is targeting .NET 3.5 and is installing 4.5 as a
> prerequisite.  Curiously enough, I am initially able to install .NET 4.5,
> and load my custom bootstrapper.  However, if I subsequently uninstall .NET
> via ARP, and run my bootstrapper a 2nd time, then I consistently get the
> above error.  The test environment is running Windows 7 with .NET 3.5
> enabled.  Here is my bootstrappercore.config
>
> <?xml version="1.0" encoding="utf-8" ?>
> <configuration>
>
>   <configSections>
>     <sectionGroup name="wix.bootstrapper"
>
> type="Microsoft.Tools.WindowsInstallerXml.Bootstrapper.BootstrapperSectionGroup,
> BootstrapperCore">
>       <section name="host"
> type="Microsoft.Tools.WindowsInstallerXml.Bootstrapper.HostSection,
> BootstrapperCore" />
>     </sectionGroup>
>   </configSections>
>
>   <startup useLegacyV2RuntimeActivationPolicy="true">
>     <supportedRuntime version="v4.0" />
>   </startup>
>
>   <wix.bootstrapper>
>     <host assemblyName="MyBootstrapperApplication">
>       <supportedFramework version="v3.5" />
>     </host>
>   </wix.bootstrapper>
>
> </configuration>
>
> Can someone please advise whether this is a WiX bug or I am doing something
> wrong?  Thanks in advance.
>
> Brian
>
> ------------------------------------------------------------------------------
> _______________________________________________
> WiX-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/wix-users
>
------------------------------------------------------------------------------
_______________________________________________
WiX-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/wix-users